WordPress自动升级出错的原因多半是写权限问题,尤其容易出现在开启了selinux的机器上。在升级过程中失败了,站点无法打开,可以手动升级进行补救:

  1. 保持wp-content不要动
  2. 手动下载wordpress.tar.gz,解压之后,覆盖wp-admin和wp-includes两个目录
  3. 如果wp-config.php不幸被修改了,那就重新填写一遍数据库连接信息
  4. 对比wordpress根目录下的其他php文件,留意变动。一般情况没有变化,我这次从4.x升级到5.0只发现了wp-login.php有稍许变动

满血复活。

升级之前务必备份wordpress目录和数据库,这样最坏情况实在无法手动处理升级,还可以回滚到升级前的状态。解决权限问题之后再进行升级。


发表评论

电子邮件地址不会被公开。 必填项已用*标注

我不是机器人*